Von der Fernwartung ausgebremst

WLAN-Problem nach einem Firmware-Update an einem O₂-Router

Manche Internet-Provider stellen einen eigenen Router zwingend zur Verfügung, der den Usern keine Kontrolle über Firmware-Updates erlaubt. Updates werden im Rahmen der Fernwartung ausgespielt, ohne dass die User davon etwas mitbekommen. Dass so ein Update aber auch das WLAN lahmlegen kann, wird nachfolgend beschrieben. Insofern hat die davon betroffene Userin doch etwas mitbekommen …

Das Problem

Ein Laptop konnte sich plötzlich nicht mehr mit dem WLAN verbinden. Er hat das gewohnte Funknetz im 2,4-GHz-Band nicht mehr erkannt. Meinen iPhone-Hotspot und ein Dutzend Netze in der Nachbarschaft hat er sofort gemeldet und ließ sich problemlos mit meinem Hotspot verbinden.

Der Laptop hat einen WLAN-Chip für den Standard IEEE 802.11n. In dem besagten Router lässt sich einstellen, nach welchem Standard er im 2,4-GHz-Band senden soll: nach „b/g/n“ oder nur nach „n“. Eingestellt war „b/g/n“ (linker Teil der Abbildung), und mit dieser Einstellung sollte es eigentlich funktionieren – und hat es ja bisher auch.

Benutzeroberfläche eines O₂-Routers, Enstellung des Funkstandards für das 2,4-GHz-Band
Der O₂-Router erlaubt für das 2,4-GHz-Band die Einstellungen „b/g/n“ (links) sowie „n“ (rechts).

Als altem Experimentierer kam mir die Idee, es mal mit der Einstellung „n“ zu versuchen (rechter Teil der Abbildung). Es wird dann nicht mit dem Client ausgehandelt, nach welchem Standard übertragen werden soll, sondern nach „n“ – oder gar nicht.

Und siehe da: Der Laptop erkannte das WLAN wieder. Dass ich auf der richtigen Fährte war, hat die Gegenprobe bestätigt: Nachdem ich den Router zurück auf „b/g/n“ gestellt hatte, war das WLAN für den Laptop wieder verschwunden.

Da das letzte Windows-Update (Windows 10) schon lange zurücklag, habe ich den Laptop über meinen Handy-Hotspot auf den aktuellen Stand gebracht – in der Hoffnung dass dabei auch der Treiber für den WLAN-Chip aktualisiert würde. Nachdem das Update installiert war, hat der Laptop das WLAN tatsächlich wieder erkannt, egal ob der Router auf „b/g/n“ oder „n“ eingestellt war.

Unglückliche Verkettung

Das ungefragt aufgespielte Firmware-Update hat den Laptop am Verbinden mit dem WLAN gehindert. Dabei war das Update aber nur bedingt schuld, denn alle anderen Geräte im Haushalt haben das WLAN ja weiterhin gefunden. In dem einen Laptop ist offenbar ein WLAN-Chip verbaut, der erst nach dem Treiber-Update wieder richtig funktionierte.

Ein bisschen rätselhaft ist das Verhalten aber schon, denn der Standard „n“ stammt von 2009, „b“ und „g“ sind noch einige Jahre älter. An diesen Standards wurde sicher nichts geändert. Aber offenbar an der Umsetzung im Router und am Treiber des Chips im Laptop.

Schreibe einen Kommentar